1С бухгалтерия

Собственно проблема в заголовке. Обнаружил в 534-м релизе.

Если РезультатФФОМС <> 0 Тогда 
	// ХА
	ИмяШкалыВзносов = "ФФОМС";
	СтавкаТарифа = глПолучитьСтавкуВзноса(ВидТарифа,ИмяШкалыВзносов,ДатаКон) / 100;
	// 		ХА
	ТаблицаРаспределения = РаспределитьВзносыПоНачислениям(РезультатФФОМС, НачисленияФОМС, СтавкаТарифа, СтавкаТарифаИнвалид, Инвалид, ИмяШкалыВзносов, МатПомощьЕдиновременная, МатПомощьПриРождении);				
	ТаблицаРаспределения.ВыбратьСтроки();
	Пока ТаблицаРаспределения.ПолучитьСтроку() = 1 Цикл
		СформироватьПроводку("ФФОМС", Сотрудник, ТаблицаРаспределения, ТаблицаРаспределения.Сумма + ТаблицаРаспределения.СуммаЕНВД);
		СформироватьПроводкуСВЗ("ФФОМС", Сотрудник, ТаблицаРаспределения.Сумма + ТаблицаРаспределения.СуммаЕНВД, 0, ТаблицаРаспределения);
	КонецЦикла;
КонецЕсли;
 
Если РезультатТФОМС <> 0 Тогда
	// ХА
	ИмяШкалыВзносов = "ТФОМС";
	СтавкаТарифа = глПолучитьСтавкуВзноса(ВидТарифа,ИмяШкалыВзносов,ДатаКон) / 100;
	// 		ХА
	ТаблицаРаспределения = РаспределитьВзносыПоНачислениям(РезультатТФОМС, НачисленияФОМС, СтавкаТарифа, СтавкаТарифаИнвалид, Инвалид, ИмяШкалыВзносов, МатПомощьЕдиновременная, МатПомощьПриРождении);				
	ТаблицаРаспределения.ВыбратьСтроки();
	Пока ТаблицаРаспределения.ПолучитьСтроку() = 1 Цикл
		СформироватьПроводку("ТФОМС", Сотрудник, ТаблицаРаспределения, ТаблицаРаспределения.Сумма + ТаблицаРаспределения.СуммаЕНВД);
		СформироватьПроводкуСВЗ("ТФОМС", Сотрудник, ТаблицаРаспределения.Сумма + ТаблицаРаспределения.СуммаЕНВД, 0, ТаблицаРаспределения);
	КонецЦикла;
КонецЕсли;

Отправить комментарий

Содержание этого поля является приватным и не предназначено к показу.
  • Адреса страниц и электронной почты автоматически преобразуются в ссылки.
  • Доступны HTML теги: <a> <em> <strong> <cite> <code> <ul> <ol> <li> <dl> <dt> <dd>
  • Строки и параграфы переносятся автоматически.
  • You can enable syntax highlighting of source code with the following tags: <code>, <blockcode>, <1c7>, <drupal5>, <drupal6>, <javascript>, <php>. Beside the tag style "<foo>" it is also possible to use "[foo]".