1С бухгалтерия

Собственно суть проблемы изложена в названии темы. Релиз 179, т.е. на сегодняшний день самый свежий и до сих пор ФСС НС удерживается с материальной помощи в полном объеме, хотя, как известно с 2011 года должно действовать такое же правило как и для всех страховых взносов, а именно с 4000 налог удерживаться не должен.

Начинаем править модуль документа ЗакрытиеМесяца.

...
	КоррФСС = КоррФСС + КоррФСССотр;
 
	ВсегоФСС = ВсегоФСС + ВсегоФСССотр;
 
КонецЕсли;// ВзиматьСтраховыеВзносы
 
//ФСС от НС и ПЗ 
 
// ХА
СкидкаМатПомощьПоТекущийМесяц = ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы,11);
СкидкаМатПомощьИнвалидПоТекущийМесяц = ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы,11+13);
СкидкаМатПомощьЕНВДПоТекущийМесяц = ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы,11+26);
 
ИсчисленоПоПредыдущийМесяц = 0;
ИсчисленоПоПредыдущийМесяцИнвалид= 0;
ИсчисленоПоПредыдущийМесяцЕНВД = 0;
Если Месяц >1 Тогда
	СкидкаМатПомощьПоПредыдущийМесяц = ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы-1,11);
	СкидкаМатПомощьИнвалидПоПредыдущийМесяц = ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы-1,11+13);
	СкидкаМатПомощьЕНВДПоПредыдущийМесяц = ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы-1,11+26);
КонецЕсли;
СкидкаМатПомощь = СкидкаМатПомощьПоТекущийМесяц + СкидкаМатПомощьИнвалидПоТекущийМесяц + СкидкаМатПомощьЕНВДПоТекущийМесяц - СкидкаМатПомощьПоПредыдущийМесяц - СкидкаМатПомощьИнвалидПоПредыдущийМесяц - СкидкаМатПомощьЕНВДПоПредыдущийМесяц;
// 		ХА     
 
 
ОблагаемаяБазаПоТекущийМесяцТаблица	= ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы,"ОграниченнаяБаза");
 
НачисленияФССотНСиПЗ = ВернутьТаблицуНачислений(ТаблицаНачислений,Сотрудник,"ФССотНС");
 
Если ДатаГод(ДатаДок) > 2010 Тогда
	НачисленияФССотНСиПЗ.Свернуть("Счет,Субконто1,Субконто2,Субконто3,Инвалид","Сумма,СуммаЕНВД,МатПомощьЕдиновременная,МатПомощьПриРождении,МатПомощьЕдиновременнаяЕНВД,МатПомощьПриРожденииЕНВД");
КонецЕсли;
 
НачисленияФССотНСиПЗ.НоваяКолонка("СуммаФССНСиПЗ");
СуммаФССНСиПЗ = 0;				
НачисленияФССотНСиПЗ.ВыбратьСтроки();
Пока НачисленияФССотНСиПЗ.ПолучитьСтроку()=1 Цикл
	// ХА
	ТекСкидкаМатПомощь = Мин(НачисленияФССотНСиПЗ.МатПомощьЕдиновременная + НачисленияФССотНСиПЗ.МатПомощьЕдиновременнаяЕНВД,СкидкаМатПомощь);
	СкидкаМатПомощь = Макс(СкидкаМатПомощь - ТекСкидкаМатПомощь,0);
	// 		ХА
	Если НачисленияФССотНСиПЗ.Инвалид = 0 Тогда						
		Если ДатаГод(ДатаДок)<2010 Тогда
			НачисленияФССотНСиПЗ.СуммаФССНСиПЗ = Окр(НачисленияФССотНСиПЗ.Сумма  * СтФССотНС/100,2,1) +  Окр(НачисленияФССотНСиПЗ.СуммаЕНВД  * СтФССотНС/100,2,1);
		Иначе
			// ХА
			НачисленияФССотНСиПЗ.СуммаФССНСиПЗ = (НачисленияФССотНСиПЗ.Сумма+НачисленияФССотНСиПЗ.СуммаЕНВД-ТекСкидкаМатПомощь)  * СтФССотНС/100;
			//НачисленияФССотНСиПЗ.СуммаФССНСиПЗ = НачисленияФССотНСиПЗ.Сумма  * СтФССотНС/100 +  НачисленияФССотНСиПЗ.СуммаЕНВД  * СтФССотНС/100;
			// 		ХА
		КонецЕсли;
 
		СуммаФССНСиПЗ = СуммаФССНСиПЗ + НачисленияФССотНСиПЗ.СуммаФССНСиПЗ;
	Иначе						
		Если ДатаГод(ДатаДок)<2010 Тогда
			НачисленияФССотНСиПЗ.СуммаФССНСиПЗ = Окр(НачисленияФССотНСиПЗ.Сумма  * СтФССотНС * 0.6/100,2,1) + Окр(НачисленияФССотНСиПЗ.СуммаЕНВД  * СтФССотНС * 0.6/100,2,1);
		Иначе
			// ХА
			НачисленияФССотНСиПЗ.СуммаФССНСиПЗ = (НачисленияФССотНСиПЗ.Сумма+НачисленияФССотНСиПЗ.СуммаЕНВД-ТекСкидкаМатПомощь)  * СтФССотНС * 0.6/100;
			//НачисленияФССотНСиПЗ.СуммаФССНСиПЗ = НачисленияФССотНСиПЗ.Сумма  * СтФССотНС * 0.6/100 + НачисленияФССотНСиПЗ.СуммаЕНВД  * СтФССотНС * 0.6/100;
			// 		ХА
		КонецЕсли;
		СуммаФССНСиПЗ = СуммаФССНСиПЗ + НачисленияФССотНСиПЗ.СуммаФССНСиПЗ;
	КонецЕсли;
 
	СводныеНачисленияФССотНСиПЗ.НоваяСтрока();
	СводныеНачисленияФССотНСиПЗ.Счет = НачисленияФССотНСиПЗ.Счет;
	СводныеНачисленияФССотНСиПЗ.Субконто1 = НачисленияФССотНСиПЗ.Субконто1;
	СводныеНачисленияФССотНСиПЗ.Субконто2 = НачисленияФССотНСиПЗ.Субконто2;
	СводныеНачисленияФССотНСиПЗ.Субконто3 = НачисленияФССотНСиПЗ.Субконто3;
	СводныеНачисленияФССотНСиПЗ.СуммаФССНСиПЗ = НачисленияФССотНСиПЗ.СуммаФССНСиПЗ;
 
	Если ДатаГод(ДатаДок) > 2010 Тогда
...

Отправить комментарий

Содержание этого поля является приватным и не предназначено к показу.
  • Адреса страниц и электронной почты автоматически преобразуются в ссылки.
  • Доступны HTML теги: <a> <em> <strong> <cite> <code> <ul> <ol> <li> <dl> <dt> <dd>
  • Строки и параграфы переносятся автоматически.
  • You can enable syntax highlighting of source code with the following tags: <code>, <blockcode>, <1c7>, <drupal5>, <drupal6>, <javascript>, <php>. Beside the tag style "<foo>" it is also possible to use "[foo]".