1С бухгалтерия

После переноса остатков в 1С БГУ, возникла необходимость подравить документы "Операция ввод остатков". В частности было много пустых субконто по счетам расчетов с контрагентами и хотелось все это прикрыть автоматической обработкой. Но возник вопрос, как работать с этим документом.

Пример того, как там можно вносить изменения:

Набор = РегистрыБухгалтерии.ЕПСБУ.СоздатьНаборЗаписей();
Набор.Отбор.Регистратор.Установить(ДокВводОстатков.Ссылка);
Набор.Прочитать();
ТЗ = Набор.Выгрузить();
 
Массив = Новый Массив;
Массив.Добавить(Тип("СправочникСсылка.Контрагенты"));
ОписаниеТиповКонт = Новый ОписаниеТипов(Массив);
 
Массив = Новый Массив;
Массив.Добавить(Тип("СправочникСсылка.Договоры"));
ОписаниеТиповДог = Новый ОписаниеТипов(Массив);
 
Для Ном = 0 По ТЗ.Количество() - 1 Цикл
	СтрокаТЗ = ТЗ.Получить(Ном);
	Если СтрокаТЗ.ВидСубконтоДт2.ТипЗначения = ОписаниеТиповКонт Тогда
		Если СтрокаТЗ.СубконтоДт2.Пустая() Тогда
			СтрокаТЗ.СубконтоДт2 = ПрочийКонтрагент;
		КонецЕсли;
		Если СтрокаТЗ.ВидСубконтоДт3.ТипЗначения = ОписаниеТиповДог Тогда
			Если СтрокаТЗ.СубконтоДт3.Пустая() Тогда
				Если СтрокаТЗ.СубконтоДт2 = ПрочийКонтрагент Тогда
					СтрокаТЗ.СубконтоДт3 = ПрочийДоговор;
				Иначе
					// Подбираем договор
				КонецЕсли;
			КонецЕсли;
		КонецЕсли;
	КонецЕсли;
КонецЦикла;
 
Набор.Загрузить(ТЗ);
Набор.Отбор.Регистратор.Установить(ДокВводОстатков.Ссылка);
Набор.Записать();

Комментарии

Выберите нужный метод показа комментариев и нажмите "Сохранить установки".

Спасибо Вам!

Спасибо за совет.
Проверенно работает.

Спасибо, очень помогло!!!

Отправить комментарий

Содержание этого поля является приватным и не предназначено к показу.
  • Адреса страниц и электронной почты автоматически преобразуются в ссылки.
  • Доступны HTML теги: <a> <em> <strong> <cite> <code> <ul> <ol> <li> <dl> <dt> <dd>
  • Строки и параграфы переносятся автоматически.
  • You can enable syntax highlighting of source code with the following tags: <code>, <blockcode>, <1c7>, <drupal5>, <drupal6>, <javascript>, <php>. Beside the tag style "<foo>" it is also possible to use "[foo]".