1С бухгалтерия

После обновления на 318 релиз при формировании сравки 2НДФЛ вылазит такая ошибка:

СуммыВычетов[Номер]=СуммыВычетов[Номер]+СуммаВычета;
{Глобальный модуль(34495)}: Значение индексного выражения находится за границами массива

Проявлятся будет не у всех баз. В моем случае была база, где в справочнике вычетов были, например, два элемента - один с кодом "108", другой с кодом "114\108". Хотя, вроде бы, вручную этот справочник не правили. В общем не знаю как так получилось. Ну и для элемента с кодом "108" пустой реквизит "Код с 2011 г.". Вот отсюда и идет ошибка.
Надо заполнить этот реквизит.

Обработка для замены вычетов. С помощью этой обработки все вычеты с кодом 108 приводятся к вычету с кодом 114\108 и если есть второй ребенок, то код меняется на 115.

Прикрепленный файлРазмерХитыПоследнее скачивание
UstanovkaVychetov2011.ert71.5 кб30561 день 4 часа назад

Комментарии

Выберите нужный метод показа комментариев и нажмите "Сохранить установки".

вообще с НДФЛ-ом не понятки полезли после обновления. Не правильно считает у некоторых -особенно у тех у кого много детей не совершенно-летних

admin аватар

Согласен. Клиенты тоже жаловались. Я просил их мне базу сбросить чтобы я посмотрел, но никто так и не сбросил, видимо че-то сами подправляли вручную.

admin аватар

Добавил обработку для корректировки вычетов по детям

Просто огромнейшее спасибо, Вы меня натолкнули на мысль - проверил - точно Она.
Бухи - когда налоговые вычеты указывали - на первого и на второго ребёнка указывали код 114, а надо на первого 114, на второго 115, на третьего 116

Прегромное спасибо!!!! Помогло

Та ж проблема в бухгалтерии 532(( Эта обработка не помогла.( Подскажите что делать?

Добрый день! у меня таже ошибка, попробовала обработку - ничего не меняется... может базу показать?

admin аватар

Ребят, поймите правильно. И базу бы посмотрел и в бухгалтерии 532 бы покопался. Но не в январе :( Катастрофически не хватает времени. Я за деньги-то не успеваю всем помочь, поэтому решать чужие проблемы сейчас не могу. Каждый день домой поздно возвращаюсь, проверяю почту, а там какая-нибудь база клиентов уже ждет либо обновления, либо исправления косяков после обновления :)

А у вас база "Зарплата и Кадры" или тоже "Бухгалтерия" ?

У меня Зарплата и кадры...обновилась до 319, но ошибка сохранилась...а может подскажите где покапаться?я сама попробую...

admin аватар

А у вас ошибка один в один как эта:
СуммыВычетов[Номер]=СуммыВычетов[Номер]+СуммаВычета;
{Глобальный модуль(34495)}: Значение индексного выражения находится за границами массива

Если да, то тогда второй вопрос. У вас в справочнике видов вычетов тоже двойные вычеты с кодами 108?

Ошибка один в один такая же,а в справочнике после обновления открывается таблица с вычетами старыми и новыми значениями и код 108 идет один раз 114/108 как вычет на первого ребенка...

admin аватар

Тогда так сложно сказать что там у вас. Я помнится около часа ловил в отладчике эту ошибку. Причину своей ошибки я описал. У вас похоже что-то другое. Тоже надо конкретно в вашей базе с отладчиком сидеть.

Осталось найти специалиста кто мог бы помочь отловить ошибку... Самой мне с новорожденным ребенком на руках не справиться)))

Я тут внимательно посмотрела чего мне ругает программа, так вот :
СуммыВычетов[Номер]=СуммыВычетов[Номер]+СуммаВычета;
{Глобальный модуль(34479)}: Значение индексного выражения находится за границами массива
отличие от вашей ошибки номер глобального модуля...

admin аватар

Номер разный потому, что у меня не совсем типовой глобальный модуль. База у вас большая? Если не большая, то присылайте, погляжу.

Спасибо большое! база маленькая, я отправила.

admin аватар

У вас проблемы с целостностью базы. Посмотрите на сотрудника Крупенина, а точнее на ее вычеты. Там <объект не найден>, т.е. вид вычета отсутствует, а ссылка на него есть. Ошибка возникает когда имеются виды вычетов, о которых программа не знает и ваш пустой вид вычета из этого числа.

Запускайте в Конфигураторе Администрирование-Тестирование и исправление, потом уже в базе пересмотрите еще раз у всех вычеты(благо у вас сотрудников не много) и советую либо перепроверить либо пересчитать НДФЛ.

у меня получилось по аналогии /1с 7 бухгалтерия/пропала эта ошибка, спасибо Вам, распечатываю справки по НДФЛ- и даже глазам не верю-)))))))

Отпишитесь пожалуйста как будут результаты по бухгалтерии.

УРААААА!!!!!!! ВСЕ ПОЛУЧИЛОСЬ!!!! ОГРОМЕННОЕ ВАМ СПАСИБО!!!!!!!!!!!!!!

Спасибо! Очень полезно!

Здравствуйте. Программа 1С: Предприятие 7.7., реализ 535. При корректировке данных НДФЛ, при формировании любых справок НДФЛ, выскакивает ошибка: "СуммыВычетовП[Номер]=СуммыВычетовП[Номер]+Сумма Вычета; {Глобальный модуль(22496)}: Значение индексного выражения находится за границами массива"
Глобальный модуль отличается от Вашего. Что может быть в моем случае?

Файл: Обработка для замены вычетов, поможет ли в моем случае? В какой каталог его копировать?

admin аватар

Поможет или нет не знаю. В любом случае сначала копию базы сделайте, потом запускайте обработку. Обработку можно запустить просто открыв ее из меню Файл - Открыть.

А у меня выдается ошибка Если сумма вычетов больше 0 тогда глобальный модуль 34541 : Значение индексного выражения находится за границами массива.
Вчера обновляла зарплату и кадры сегодня при подсчете ндс вылезла эта абра-кодабра что делать не знаю(

admin аватар

Я вам так вслепую тоже вряд ли смогу помочь. Еще хотел узнать, а ндс - это что такое?

не ндс, ндфл) торопилась вчера) Там эта тема вылазит при расчете зп одному сотруднику уволившемуся в 2002.. бух считает зп абсолютно всем, решили проблему так что считать она стала только работающим в данный момент людям. А этот человек устраивался в фирму на работу два раза первый раз уволился в 2001 второй раз в 2002 можно конечно просто его удалить но боюсь база поплывёт поэтому оставила а зп сказала начислять только по тем , кто работает. ЗиК релиз 320 поставила.

А проще вот такой обработкой это сделать! Только пробуйте на копии.

//*******************************************
Выч=СоздатьОбъект("Справочник.ВидыВычетов");
Выч.НайтиПоКоду("108\101",0);
Испр108=Выч.ТекущийЭлемент();
Выч.НайтиПоКоду("109\106",0);
Испр109=Выч.ТекущийЭлемент();
Выч.НайтиПоКоду("110\102",0);
Испр110=Выч.ТекущийЭлемент();
Выч.НайтиПоКоду("112\107",0);
Испр112=Выч.ТекущийЭлемент();
Выч.НайтиПоКоду("313\311",0);
Испр313=Выч.ТекущийЭлемент();
Спр=СоздатьОбъект("Справочник.Сотрудники");
Спр.ВыбратьЭлементы();
Пока Спр.ПолучитьЭлемент()=1 Цикл
Выч=СоздатьОбъект("Справочник.ВычетыСотрудниковПоНДФЛ");
Выч.ИспользоватьВладельца(Спр.ТекущийЭлемент());
Выч.ВЫбратьЭлементы();
Пока ВЫч.ПолучитьЭлемент()=1 Цикл
Если Выч.ВидВычета.Код="108" Тогда
Сообщить(""+Спр.ТекущийЭлемент()+" меняю "+Выч.ВидВычета+" на "+Испр108,"!");
Выч.ВидВычета=Испр108;
Выч.Записать();
ИначеЕсли Выч.ВидВычета.Код="109" Тогда
Сообщить(""+Спр.ТекущийЭлемент()+" меняю "+Выч.ВидВычета+" на "+Испр109,"!");
Выч.ВидВычета=Испр109;
Выч.Записать();
ИначеЕсли Выч.ВидВычета.Код="110" Тогда
Сообщить(""+Спр.ТекущийЭлемент()+" меняю "+Выч.ВидВычета+" на "+Испр110,"!");
Выч.ВидВычета=Испр110;
Выч.Записать();
ИначеЕсли Выч.ВидВычета.Код="112" Тогда
Сообщить(""+Спр.ТекущийЭлемент()+" меняю "+Выч.ВидВычета+" на "+Испр112,"!");
Выч.ВидВычета=Испр112;
Выч.Записать();
ИначеЕсли Выч.ВидВычета.Код="313" Тогда
Сообщить(""+Спр.ТекущийЭлемент()+" меняю "+Выч.ВидВычета+" на "+Испр313,"!");
Выч.ВидВычета=Испр313;
Выч.Записать();
КонецЕсли;
КонецЦикла;
КонецЦикла;
ВЫч=СоздатьОбъект("Справочник.ВидыВычетов");
Выч.ВыбратьЭлементы();
Пока Выч.ПолучитьЭлемент()=1 Цикл
Если Выч.Код="108" Тогда
Сообщить("Удален вычет "+ВЫч.ТекущийЭлемент());
выч.Удалить(1);
ИначеЕсли Выч.Код="109" Тогда
Сообщить("Удален вычет "+ВЫч.ТекущийЭлемент());
выч.Удалить(1);
ИначеЕсли Выч.Код="110" Тогда
Сообщить("Удален вычет "+ВЫч.ТекущийЭлемент());
выч.Удалить(1);
ИначеЕсли Выч.Код="112" Тогда
Сообщить("Удален вычет "+ВЫч.ТекущийЭлемент());
выч.Удалить(1);
ИначеЕсли Выч.Код="313" Тогда
Сообщить("Удален вычет "+ВЫч.ТекущийЭлемент());
выч.Удалить(1);
КонецЕсли;
КонецЦикла;
//*******************************************

Здравствуйте! У меня в 1С 7.7.релиз 7.70.535. Однако, справки 2-НДФЛ формируются по старой форме. Нового релиза не видела. Помогите, пожалуйста-как исправить ошибку и сдать уже наконец отчетность по НДФЛ? Спасибо за оперативность

admin аватар

А в чем ошибка-то? Хоть и не на общем режиме, а на УСН (но тоже 7.7), сегодня без проблем выгрузил справки и загрузил в СБИС. Что у вас не получается?

После обновления ЗИК 320,321 появилась ошибка при расчете зарплаты

СуммыВычетов[Номер]=СуммыВычетов[Номер]+СуммаВычета;
{Глобальный модуль(34522)}: Значение индексного выражения находится за границами массива

Кто знает как решить ?
Как создать новую тему не разобрался...

admin аватар

Тут не форум, а блог, поэтому новые темы создаю только я. До форума все руки никак не доходят. По поводу вашей ошибки, вы все уже перепробовали о чем здесь говорилось?

admin аватар

Хочу дополнить по поводу этой фразы "Для элемента с кодом "108" пустой реквизит "Код с 2011 г.". Надо заполнить этот реквизит."
Лучше всего в качестве кода поставить 108, а не 114, в противном случае даже если у сотрудника выбран вычет с кодом 108/114, при расчете будет почему-то задействован старый вычет с кодом 108. У меня это всплыло, когда сотруднику в 2012 году были даны вычеты 1000 + 1400 (хотя должно 1400+1400).

Обработка прошла на Ура. Мне сегодня бухи выносили мозг со 108 вычетом. XML-ка не корректно загружалась в Налогоплательщик 2011. Поменял вычет 108 на 114/115, сделал выгрузку, дописал обработку чтобы обратно все вернуть 114/115 в 108. Пасип!!!!

admin аватар

Налогоплательщик 2011 покупали? А то вроде бы он в бесплатной версии выгружать потом не дает.

Зачем покупать? Мы же в России живем. :-) Нужно скопировать "Readme2.txt" из рабочей версии Налогоплательщика. Я копировал из "Налогоплательщик 2010". По адресу C:\Npw\2010 и вставить в C:\Npw\2011. Т.е. подменить файл. Для того что бы включить авторасчет, в базе каждой организации есть файлик spisok.dbf. меняем поле avto с 0 на 1. DBF-ку открываем программой DBFNavigator.

admin аватар

Понятно, что в России, но чтобы защита была на таком уровне... Не знал об этой фишке с Readme2.txt. Спасибо.

релиз 535, зайдите в сотрудника и в вычеты, и поменяйте код вычета (аллергия на 103 вычет) . Ошибка исчезнет

Так, а на что поменять 103 вычет?

Здравствуйте. (1c 7.7 ЗиК 322) Была ошибка:
"СуммыВычетов[Номер]=СуммыВычетов[Номер]+СуммаВычета;
{Глобальный модуль(34495)}: Значение индексного выражения находится за границами массива"
Избавился от ошибки добавив в строке кода 108\114 для 2011 года, код 108. но при расчете НДФЛ не считает льготы на первого и второго ребёнка, на 3-го считает. Делал все пересчёты, ошибок не возникает.
Помогите кто чем сможет.

Проблема решена. добавив в строке кода 108\114 для 2011 года, код не 108, а 114 в остальных строках аналогично.

спасибо работает весь инет перерыл, а такую строчку(((

Здравствуйте, у меня такая ошибка при формировании справок:
СуммыВычетов[Номер]=СуммыВычетов[Номер]+СуммаВычета;
{Глобальный модуль(22258)}: Значение индексного выражения находится за границами массива

Запускала обработку, не помогло, вычеты на детей вообще не использую, у меня только 103.
База Бухгалтерия 7,7

что можно сделать для исправления этой ошибки?
Спасибо.

admin аватар

Я думаю, что проблемы все таки носят единичный характер, в том смысле что программа спотыкается на каком-то сотруднике и дальше не идет. В общем случае проще всего проблемную строку обернуть в Попытку:

Попытка
	СуммыВычетов[Номер]=СуммыВычетов[Номер]+ВычетыТекущие[Номер];
Исключение
	Сообщить(Сотрудник.Наименование);
КонецПопытки;

и уже потом рассматривать что не так с тем или иным сотрудником.

Спасибо, не получается у меня ничего, буду ждать следующего релиза, может он инсправит эти глюки.

По 1С7.7 зарплата и Кадры выдает ошибку. Что делать?

СуммыВычетов[Номер]=СуммыВычетов[Номер]+СуммаВычета;
{Глобальный модуль(34484)}: Значение индексного выражения находится за границами массива

Зд-те.Релиз 537.При форми-нии НДФЛ ВЫДАЕТСЯ :СуммыВычетов[Номер]=СуммыВычетов[Номер]+СуммаВычета;
{Глобальный модуль(22258)}: Значение индексного выражения находится за границами массива. Может это:Была мат.помощь,код 503,а как его внести в карточку вычетов сотрудника,не подсажете? Сп.

admin аватар

Если я не ошибаюсь, достаточно правильно указать код дохода в виде расчета Мат. помощь. А потом при желании сделать перерасчет НДФЛ(если налог был не правильно посчитан из-за этого).

он указан. Но ведь должен появиться соотв-щий код вычета и в карточке сотрудника? его же нет, да и вручную не вводиться

admin аватар

Может не туда смотрите. Вычет появляется автоматом как только в виде расчета указан правильный код дохода. Даже если тупо какому-нибудь левому виду расчета назначить код 2760, то без всяких перерасчетов в регистре НДФЛ и в справке 2НДФЛ появляется вычет и даже исчисленная сумма налога меняется.

Отправить комментарий

Содержание этого поля является приватным и не предназначено к показу.
  • Адреса страниц и электронной почты автоматически преобразуются в ссылки.
  • Доступны HTML теги: <a> <em> <strong> <cite> <code> <ul> <ol> <li> <dl> <dt> <dd>
  • Строки и параграфы переносятся автоматически.
  • You can enable syntax highlighting of source code with the following tags: <code>, <blockcode>, <1c7>, <drupal5>, <drupal6>, <javascript>, <php>. Beside the tag style "<foo>" it is also possible to use "[foo]".