1С бухгалтерия

Переношу документы из 1С Бухгалтерии 7.7. в Бухгалтерию 3.0. Столкнулся с тем, что по счету 08.3 у меня не корректно перенеслись данные по субконто. Если быть точнее, то последнее субконто в 7-ке становится первым в 8-ке, а остальные субконто просто не переносятся.
Стал смотреть что там происходит в правилах переноса и выяснилось, что почти везде, где встречается реквизит "субконто" в функции ПередВыгрузкой вызывается вот такой код:

Параметры.ПараметрыАлгоритмов.Установить("Счет", Источник.Счет);
Параметры.ПараметрыАлгоритмов.Установить("Субконто1", Источник.Субконто1);
Параметры.ПараметрыАлгоритмов.Установить("Субконто2", Источник.Субконто2);
Параметры.ПараметрыАлгоритмов.Установить("Субконто3", Источник.Субконто3);
 
Параметры.ПараметрыАлгоритмов.Установить("Субконто", Источник.Субконто3);
ПриВыгрузкеСубконто();

Реквизиты Счет и СубконтоХ могут иметь другие названия, но суть не меняется. В свою очередь в функции ПриВыгрузкеСубконто() мы имеем такое начало:

Счет = Параметры.ПараметрыАлгоритмов.Получить("Счет");
Субконто = Параметры.ПараметрыАлгоритмов.Получить("Субконто");
НомерСубконто = Параметры.ПараметрыАлгоритмов.Получить("НомерСубконто");
ДтКт = Параметры.ПараметрыАлгоритмов.Получить("ДтКт");
ВидДоговора = "Прочее";

И дальше по тексту используется переменная НомерСубконто. А она в большинстве случаев получается просто не задана и соответственно имеем глючный перенос данных. Тут два варианта: либо перелапачивать все правила конвертации и прописывать установку номера субконто, либо попробовать отредактировать функцию ПриВыгрузкеСубконто(). Я пошел вторым путем и добавил в начале функции такой код:

// ХА
Если ПустоеЗначение(НомерСубконто) = 1 Тогда
	Если ПустоеЗначение(Параметры.ПараметрыАлгоритмов.Получить("Субконто1")) = 0 Тогда
		Если Субконто = Параметры.ПараметрыАлгоритмов.Получить("Субконто1") Тогда
			НомерСубконто = 1;
		КонецЕсли;
	КонецЕсли;
	Если ПустоеЗначение(Параметры.ПараметрыАлгоритмов.Получить("Субконто2")) = 0 Тогда
		Если Субконто = Параметры.ПараметрыАлгоритмов.Получить("Субконто2") Тогда
			НомерСубконто = 2;
		КонецЕсли;
	КонецЕсли;
	Если ПустоеЗначение(Параметры.ПараметрыАлгоритмов.Получить("Субконто3")) = 0 Тогда
		Если Субконто = Параметры.ПараметрыАлгоритмов.Получить("Субконто3") Тогда
			НомерСубконто = 3;
		КонецЕсли;
	КонецЕсли;
КонецЕсли;
// 		ХА

Может быть где-то и споткнется об этот код, но по крайней мере данные по счету 08.3 я перетащил как полагается.

Комментарии

Выберите нужный метод показа комментариев и нажмите "Сохранить установки".

Добрый день !

Ковыряю эти же правила и столкнулся с проблемой переброски субконто по 73.3 счету,
никак не вкурю где нужно подправить что бы он нормально цеплял, физ лицо ?
Мне кажется проблема там в том что в семерке используется субконто сотрудники, а в 8-ке
на этом счете РаботникиОрганизаций(а они идут справочником физ.лица).

Но вроде как в ПКО "ВидыСубконтоХозрасчетные" стоит соответствие.

Куда копать ума не приложу, может можете помочь ? в КД до этого делал только простенькие вещи.

admin аватар

Сам не слишком часто пользуюсь КД. По 73-му счету у меня скорее всего не было остатков и оборотов, поэтому не было проблем и ничего конкретного относительно этого счета сказать не могу. Но, скорее всего, дело не в разных субконто, т.к. как вы сами же сказали, для этого вида субконто прописано правило конвертации. Поэтому тут надо ковыряться (или может быть проще вручную данные внести, т.к. счет как правило не самый ходовой). Если хотите чтобы я поковырялся, то пишите на почту.

Вот после того, как мне в какой уже раз? предложили перенести данные и одной редакции в другую, решил, что все - с меня хватит. Помню, что каждый раз какие - то косяки после этих переносов возникали постоянно. Перешел на онлайн - Мое дело - никаких тебе переносов, работаешь и работаешь

Отправить комментарий

Содержание этого поля является приватным и не предназначено к показу.
  • Адреса страниц и электронной почты автоматически преобразуются в ссылки.
  • Доступны HTML теги: <a> <em> <strong> <cite> <code> <ul> <ol> <li> <dl> <dt> <dd>
  • Строки и параграфы переносятся автоматически.
  • You can enable syntax highlighting of source code with the following tags: <code>, <blockcode>, <1c7>, <drupal5>, <drupal6>, <javascript>, <php>. Beside the tag style "<foo>" it is also possible to use "[foo]".