1С бухгалтерия

Вообще не понятно как это работает. Во-первых что касается номенклатурной группы к 90-му счету. Она не подставляется со всеми вытекающими в конце месяца при закрытии. Для того, чтобы номенклатурная группа проставлялась вроде как существует документ "Отчет о розничных продажах". Но при проведении этого документа по НТТ пишет сообщение:

В строке номер "1" табличной части "Товары": Указан собственный товар.
При учете продажных ценах продажи собственных товаров в неавтоматизированной торговой точке отражаются документом "Приходный кассовый ордер"!

Стало быть этот документ нам не подходит и надо как-то работать с ПКО. Но как. Нет там возможности указать номенклатурную группу. Можно конечно редкатировать проводки после проведения ПКО вручную и ставить там номенклатурную группу. Но это мягко говоря не удобно.

Второй вопрос, который возникает - это как приходовать выручку, если организация на УСН в и этой самой розничной выручке сидит еще и выручка, которая не подпадает под ЕНВД. Да, есть кнопка КУДиР. Но опять же, почему-то если там разбить сумму на УСН и ЕНВД, то выручка не делится на 90.01.1 и 90.01.2. Вместо этого вся выручка по прежнему относится на 90.01.2 (облагаемая ЕНВД). Нигде не нашел, как вообще в данной программе задумывалось принимать выручку из НТТ. По правильному.

В результате пришлось переделывать ПКО. В табличную часть добавил поля "Номенклатурная группа" и флажок "ЕНВД". Благо в приходнике есть кнопка Список по которой можно отредактировать суммы принимаемой выручки и разбросать по номенклатурным группам.

Сложность для бухгалтера возникает теперь в том, как правильно выделить из розничной выручки ту часть, которая относится к не ЕНВД. В моем конкретном случае к не ЕНВД относилась торговля хлебом собственного производства. И для простоты учета было принято правило, что весь хлеб, который перемещался со склада в розницу считался проданным в тот же день. Поэтому для облегчения работы я сделал внешнюю обработку, которая в конце месяца, когда проведены все перемещения в розницу и проведены все приходники, проставляет в приходники разбивку по номенклатурным группам(из справочника номенклатура) и разбивку на ЕНВД не ЕНВД.

Пример такой обработки:
korr_rozn_viruchki.epf

Комментарии

Выберите нужный метод показа комментариев и нажмите "Сохранить установки".
admin аватар

Выяснилось, что не всегда для Накладной на перемещение есть в этот день ПКО по приему розничной выручки. Пришлось сделать другую обработку, которая берет все перемещение по магазину за выбранный период и распределяет эту сумму по приходникам пропорционально суммам приходников. Эту обработку не выкладываю. Кому нужно - обращайтесь.

В результате пришлось переделывать ПКО. Подскажите как это сделать(выручка только енвд)

admin аватар

Если у вас выручка только ЕНВД, то ничего переделывать и не надо. Или я вас не совсем понял?

В результате пришлось переделывать ПКО. Подскажите как это сделать? (Выручка не ЕНВД)

admin аватар

Во-первых в бухгалтерии 2.0 с номенклатурной группой проблему наконец-то решили. А по поводу счетов и того, какие изменения я делал, то примерно так.

Добавляем два реквизита в таблицу РасшифровкаПлатежа:
ХА_НоменклатурнаяГруппа (Справочник.НомекнклатурныеГруппы)
ХА_ОтноситсяКЕНВД (Булево)
Естественно размещаем эти реквизиты в форме документа, а в модуле документа вносим парочку поправок:

Процедура ДвиженияПоРегистрам(Режим, Отказ, Заголовок ,СтруктураШапкиДокумента)
.....
ИначеЕсли ВидОперации = Перечисления.ВидыОперацийПКО.РозничнаяВыручка Тогда
.....
 
Проводка.СчетКт      = СчетВыручки;
БухгалтерскийУчет.УстановитьСубконто(Проводка.СчетКт, Проводка.СубконтоКт, "СтавкиНДС",  Строка.СтавкаНДС);
БухгалтерскийУчет.УстановитьСубконто(Проводка.СчетКт, Проводка.СубконтоКт, "НоменклатурныеГруппы",  НоменклатурнаяГруппаВыручки);
 
// ХА
Попытка
	Если Не Строка.ХА_НоменклатурнаяГруппа.Пустая() Тогда
		Если Не Строка.ХА_ОтноситсяКЕНВД Тогда
			Проводка.СчетКт = ПланыСчетов.Хозрасчетный.ВыручкаНеЕНВД;
		КонецЕсли;
		Проводка.СубконтоКт.НоменклатурныеГруппы = Строка.ХА_НоменклатурнаяГруппа; 							
	КонецЕсли;
Исключение
КонецПопытки;
// 		ХА
 
 
Проводка.Сумма       = Строка.СуммаПлатежа;
 
 
БухгалтерскийУчет.УстановитьПодразделенияПроводки(
	Проводка, СтруктураШапкиДокумента.ПодразделениеОрганизации, СтруктураШапкиДокумента.ПодразделениеОрганизации);
 
НалоговыйУчет.ЗаполнитьНалоговыеСуммыПроводки(Строка.СуммаПлатежа, (Строка.СуммаПлатежа - Строка.СуммаНДС), , , , , Проводка);
 
//списание товаров по продажным ценам
Проводка = Проводки.Добавить();
Проводка.Период      = ДатаДок;
Проводка.Организация = Организация;
Проводка.Содержание  = "Реализация товаров в розницу";
 
Проводка.СчетКт      = ПланыСчетов.Хозрасчетный.ТоварыВРозничнойТорговлеВПродажныхЦенахНТТ;
БухгалтерскийУчет.УстановитьСубконто(Проводка.СчетКт, Проводка.СубконтоКт, "СтавкиНДС",  Строка.СтавкаНДС);
БухгалтерскийУчет.УстановитьСубконто(Проводка.СчетКт, Проводка.СубконтоКт, "Склады",  СтруктураШапкиДокумента.Контрагент);
 
Проводка.СчетДт      = СчетСебестоимости;
БухгалтерскийУчет.УстановитьСубконто(Проводка.СчетДт, Проводка.СубконтоДт, "НоменклатурныеГруппы",  НоменклатурнаяГруппаВыручки);
 
Проводка.Сумма       = Строка.СуммаПлатежа;
 
// ХА
Попытка
	Если Не Строка.ХА_НоменклатурнаяГруппа.Пустая() Тогда
		Если Не Строка.ХА_ОтноситсяКЕНВД Тогда
			Проводка.СчетДт = ПланыСчетов.Хозрасчетный.СебестоимостьПродажНеЕНВД;
		КонецЕсли;
		Проводка.СубконтоДт.НоменклатурныеГруппы = Строка.ХА_НоменклатурнаяГруппа; 							
	КонецЕсли;
Исключение
КонецПопытки;
// 		ХА

Тогда в приходнике можно будет указать (в расшифровке платежа) сколько на какой счет и на какую номенклатурную группу должно уйти.

Отправить комментарий

Содержание этого поля является приватным и не предназначено к показу.
  • Адреса страниц и электронной почты автоматически преобразуются в ссылки.
  • Доступны HTML теги: <a> <em> <strong> <cite> <code> <ul> <ol> <li> <dl> <dt> <dd>
  • Строки и параграфы переносятся автоматически.
  • You can enable syntax highlighting of source code with the following tags: <code>, <blockcode>, <1c7>, <drupal5>, <drupal6>, <javascript>, <php>. Beside the tag style "<foo>" it is also possible to use "[foo]".