1С бухгалтерия

Понадобилось заполнение графы 7 "Номер и дата документа, подтверждающего уплату налога". В моем случае это при импорте товаров из государств-членов Таможенного союза.
Документ Поступление товаров есть, платежное поручение по уплате НДС есть, оформлен документ Отражение НДС к вычету, где в том числе указан документ оплаты. А в книге покупок графа 7 по данной операции не заполняется.

Почему-то при проведении документа Отражение НДС к вычету не заполняются колонки "ДатаДокументаОплаты" и "НомерДокументаОплаты" регистра накопления "НДС Покупки".
Пришлось принудительно заполнить эти реквизиты в модуле данного документа:

Процедура ДвиженияПоРегистрам(...)
....
Если СтруктураШапкиДокумента.ПрямаяЗаписьВКнигу Тогда
.....
 
		Если СтруктураШапкиДокумента.Дата >= '20150101' Тогда
			СтрокаДвижения.КодВидаОперации = СтруктураШапкиДокумента.КодВидаОперации;
		КонецЕсли;
 
		// ХА
		Попытка
			СтрокаДвижения.ДатаДокументаОплаты = СтрокаДвижения.ДокументОплаты.ДокументОснование.Дата;
			СтрокаДвижения.НомерДокументаОплаты = ОбщегоНазначения.ПолучитьНомерНаПечать(СтрокаДвижения.ДокументОплаты.ДокументОснование.Ссылка);
		Исключение
		КонецПопытки;
		// 		ХА
 
	КонецЦикла;
 
	Движения.НДСЗаписиКнигиПокупок.мПериод 			= СтруктураШапкиДокумента.Дата;
	Движения.НДСЗаписиКнигиПокупок.мТаблицаДвижений = ТаблицаДвижений_НДСЗаписиКнигиПокупок;
	Движения.НДСЗаписиКнигиПокупок.ДобавитьДвижение();
    Возврат;
 
КонецЕсли; 

Сильно заморачиваться не стал и прописал как надо было мне. В моем случае в документе ставится галка "Использовать как запись книги покупок" и в качестве документа оплаты выбирают "Списание с расчетного счета".

Отправить комментарий

Содержание этого поля является приватным и не предназначено к показу.
  • Адреса страниц и электронной почты автоматически преобразуются в ссылки.
  • Доступны HTML теги: <a> <em> <strong> <cite> <code> <ul> <ol> <li> <dl> <dt> <dd>
  • Строки и параграфы переносятся автоматически.
  • You can enable syntax highlighting of source code with the following tags: <code>, <blockcode>, <1c7>, <drupal5>, <drupal6>, <javascript>, <php>. Beside the tag style "<foo>" it is also possible to use "[foo]".