1С бухгалтерия

Сделал свой план видов характеристик и решил хранить значения в регистре сведений. В принципе ничего нового, во всех типовых конфигурациях так и сделано. В качестве измерения свойство ПВХ(имя Свойство), а в качестве ресурса Характеристика того же ПВХ(имя Значение). Поставил связь по типу и связь по владельцу в настройках реквизита Значение. Ожидал, что при выборе свойства, значение автоматом будет принимать тот тип, который задан у свойства. Но не тут то было.

Почему-то связи не происходило. При выборе Значения вываливается перечень типов, заданных в ПВХ. При чем если убрать эти Свойство и Значение из измерения и ресурса в реквизиты регистра сведений, то эта связь по типу работает без проблем. Но хотелось сделать по-человечески, поэтому пришлось кодить:

&НаКлиенте
Процедура ВводСвойстваЗавершение(Результат,Параметры) Экспорт
	Если Результат <> Неопределено Тогда
	    Запись.Свойство = Результат;
	    НовыйПараметр = Новый ПараметрВыбора("Отбор.Владелец", Результат);
	    НовыйМассив = Новый Массив();
	    НовыйМассив.Добавить(НовыйПараметр);
	    НовыеПараметры = Новый ФиксированныйМассив(НовыйМассив);
	    Элементы.Значение.ПараметрыВыбора = НовыеПараметры;		
	    Элементы.Значение.ОграничениеТипа = ПолучитьТипЗначения(Запись.Свойство);
	КонецЕсли;
КонецПроцедуры
 
&НаСервереБезКонтекста
Функция ПолучитьТипЗначения(Свойство)
	Возврат Свойство.ТипЗначения;
КонецФункции

При принудительной установке связь заработала.

Отправить комментарий

Содержание этого поля является приватным и не предназначено к показу.
  • Адреса страниц и электронной почты автоматически преобразуются в ссылки.
  • Доступны HTML теги: <a> <em> <strong> <cite> <code> <ul> <ol> <li> <dl> <dt> <dd>
  • Строки и параграфы переносятся автоматически.
  • You can enable syntax highlighting of source code with the following tags: <code>, <blockcode>, <1c7>, <drupal5>, <drupal6>, <javascript>, <php>. Beside the tag style "<foo>" it is also possible to use "[foo]".