1С бухгалтерия

Повторяться не буду, тема эта начата здесь http://www.allexx.info/perechislenie_ndfl_po_sotrudnikam_1c_zup Сейчас напишу лишь дополнение к тому, что уже сказано.
Прежде всего, меня в этом году, точнее даже еще и в прошлом, задолбало делать возврат НДФЛ, чтобы выровнять исчислено и удержано. Поэтому я сделал обработку, которая по-месячно делает возврат излишне удержанного НДФЛ. Да, в самом документе по возврату НДФЛ тоже есть кнопка заполнить, но что-то он заполняет совсем не то, что я хотел бы увидеть. Обработку можно подцепить в качестве внешней обработки табличных частей. Только не забываем, что я ее делал для АРБИС-овского ЗУП-а, поэтому под себя чуть-чуть надо подкорректировать, точнее скорее всего удалить парочку строк.

Все, теперь достаточно быстро я выровнял исчислено-удержано. Теперь перечислено. В прошлом году заморачивался над тем, чтобы в каждом месяце исчислено, удержано и перечислено были равны, из-за чего пришлось долго ковыряться. В этом году решил упростить себе жизнь и немного усовершенствовал алгоритм заполнения документов по перечислению НДФЛ. Теперь, даже если в каком-то месяце случилась переплата по НДФЛ, то при заполнении уплаты по следующему месяцу он учитывает предыдущую переплату. Ну и естественно учитывает, чтобы по году в целом никак не получилось, что перечислено больше чем удержано(ну и исчислено соответственно). Напомню, что переплата по месяцу у меня может возникнуть, если какое-то перечисление НДФЛ было сделано по конкретной ведомости, тогда в документе в комментарии делается запись об этом и этот документ уже не участвует в перераспределении уплаченного НДФЛ.

Дальше у нас появилось ОКТМО вместо ОКАТО. Соответственно, если вносили изменения в документ возврат НДФЛ, то не забываем, что надо подкорректировать свои поправки:

Если Не Отказ Тогда
	Движение = Движения.РасчетыНалоговыхАгентовСБюджетомПоНДФЛ.ДобавитьПриход();
	Движение.Период = Дата;
	Движение.МесяцНалоговогоПериода = МесяцНалоговогоПериода;
	Движение.ФизЛицо = СтрокаТЧ.ФизЛицо;
	Если ЗначениеЗаполнено(СтрокаТЧ.КодПоОКАТО) Тогда
		Движение.ОКАТО_КПП = СокрЛП(СтрокаТЧ.КодПоОКАТО) + "/" + СокрЛП(СтрокаТЧ.КПП);
	Иначе
		Движение.ОКАТО_КПП = СокрЛП(Организация.КодПоОКАТО) + "/" + СокрЛП(Организация.КПП);
	КонецЕсли;
	Если ЗначениеЗаполнено(СтрокаТЧ.КодПоОКТМО) Тогда
		Движение.ОКТМО_КПП = СтрокаТЧ.КодПоОКТМО + "/" + СокрЛП(СтрокаТЧ.КПП);
	Иначе
		Движение.ОКТМО_КПП = Организация.КодПоОКТМО + "/" + СокрЛП(Организация.КПП);
	КонецЕсли;
	Движение.Организация = Организация;
	Движение.Ставка = Перечисления.НДФЛСтавки.Ставка13;
	Движение.Сумма = -СтрокаТЧ.СуммаВозвратаПоСтавке13;
КонецЕсли;

Добавил ОКТМО в отчет по расчетам. Сначала я подумал, что могу обойтись и без ОКТМО в этом отчете. Но. Вот выровнял я исчислено-уплачено-перечислено, проверил на вскидку несколько отчетов Регистр учета НДФЛ. Все красиво. Начал заполнять справки 2НДФЛ и выяснилось, что почему-то в справках у меня не все так красиво как в регистрах. Опять эти 3 заветных цифры не сходятся. Выяснилось, что при перечислении НДФЛ несколько документов были подкорректированы после обновления связанного с ОКТМО. И в регистрах по этим документам ОКТМО не заполнился. Оказывается в документе есть скрытый реквизит ОКТМО и он не заполнен. Да и как его заполнить, если он скрытый, а после обновлений в документе по перечислению НДФЛ почему-то исчезла кнопка выбора ОКАТО. Я вернул эту кнопу на место, перевыбрал ОКАТО, перепровел и все встало как надо. Знаю, что в некоторых случаях бывают еще проблемы с пробелами в ОКТМО из-за чего может не правильно заполнятся уплаченная сумма. Поэтому в общем добавил ОКТМО в отчет.

Прикрепленный файлРазмерХитыПоследнее скачивание
PerechislenieNDFL.epf10.52 кб103219 часов 26 минут назад
VozvratNDFL.epf8.04 кб10061 час 25 минут назад
RaschetyPoNDFL.erf6.77 кб10131 неделя 2 дня назад

Отправить комментарий

Содержание этого поля является приватным и не предназначено к показу.
  • Адреса страниц и электронной почты автоматически преобразуются в ссылки.
  • Доступны HTML теги: <a> <em> <strong> <cite> <code> <ul> <ol> <li> <dl> <dt> <dd>
  • Строки и параграфы переносятся автоматически.
  • You can enable syntax highlighting of source code with the following tags: <code>, <blockcode>, <1c7>, <drupal5>, <drupal6>, <javascript>, <php>. Beside the tag style "<foo>" it is also possible to use "[foo]".