1С бухгалтерия

Подходит время для подведения итогов по НДФЛ. В этом году решил посидеть и привести исчислено, уплачено и перечислено в порядок заранее. Народу в организации много, есть разные ОКАТО.

Первым делом стал возвращать излишне удержанный НДФЛ. Точнее этот НДФЛ сотрудникам уже был выплачен, но в регистре учета НДФЛ и соответственно в справке 2НДФЛ сумма числилась как излишне удержанная. После всех возвратов вывел по организации исчислено=удержано. В некоторых случаях,кстати, удержано было меньше чем исчислено, тогда пришлось просто перепровести документы по начислению НДФЛ. Для проверки Исчислено, Удержано, Перечислено я сделал свой небольшой отчетик, который прилагаю.

Вторая проблема была с ОКАТО. Бухгалтер по своему вытаскивала сведения о том сколько нужно перечислять НДФЛ по тому или иному ОКАТО (на основании сводов по подразделениям). Ее перечисления не соответствовали данным в регистре расчетов налоговых агентов по НДФЛ. А как известно перечисление НДФЛ производится на основании этого регистра. Разница появлялась в основном по сотрудникам, которые работали сразу по нескольким ОКАТО (по совместительству). В свод по подразделению тянулся весь НДФЛ физ. лица, если выбранное подразделение является основным для данного физ. лица. Поэтому по таким сотрудникам пришлось подогнать исчисленный НДФЛ к перечисленному. Все перечисленные суммы были исправно занесены в документы Перечисление НДФЛ (без заполнения сотрудников и без проведения), поэтому перечисленный НДФЛ по ОКАТО я знал. Дал черным-красным начисления зарплаты и пересчитал по ним НДФЛ. При чем делал сначала отдельным документом красные начисления (пошла запись в регистр НДФЛ к зачету), потом делал возврат НДФЛ (закрываем НДФЛ к зачету) и потом еще один документ начисление зарплаты уже черным. Если делать в одном документе черным красным, то в регистр "НДФЛ к зачету" запись не пойдет, т.к. общая сумма НДФЛ равна 0 (по ОКАТО у нас плюс минус). И соответственно документ Возврат НДФЛ засунет в этот регистр не закрытую запись.

Еще одно дополнение. Никто толком сказать не может что делать с излишне удержанным (и наверняка уже перечисленым) НДФЛ по конкретному физ. лицу. Да, читал где-то, что переплаты по физ. лицу не бывает, бывает лишь переплата по организации вцелом. Но это все теория, а на практике я делал документы Возврат НДФЛ, чтобы выровнять расчеты с физ. лицом. Но данный документ не делает записи в регистр Расчеты налоговых агентов по НДФЛ, соответственно перечисленная сумма налога не будет совпадать с исчисленной. Поэтому я внес изменения в документ по возврату НДФЛ и заставил его добавлять Приход со знаком минус в регистр Расчеты налоговых агентов по НДФЛ. У меня в отчете "Расчеты по НДФЛ" для моего удобства удержанный НДФЛ считается как раз по этому регистру.

В итоге получил что Исчислено=Удержано. А Удержано получается это то, что должно быть перечислено и сумма удержанного НДФЛ уже равна перечисленному в разрезе ОКАТО. Осталось только раскидать имеющиеся удержанные суммы по физ. лицам в документы по перечислению НДФЛ. Для этого я написал обработку, которая заполняет заранее подготовленные документы Перечисление НДФЛ. Т.е. в документах должны быть проставлены периоды, реквизиты платежек и суммы, а обработка в эти документы подставит сотрудников с удержанными суммами.

Запускать эту обработку я думаю лучше в конце года, когда все начислено и перечислено. Как сделать по-другому, чтобы исчислено=удержано=перечислено я не очень представляю. Ведь случаи, когда человеку в январе месяце начислили и перечислили НДФЛ (допустим 100 руб.), а в феврале начинают сторнировать за январь (например -50 руб.), возникают постоянно. Поэтому при таком подходе, когда перечисление за месяц группируется уже с учетом всех начислений и сторнирований за год, то в январское перечисление попадает не 100, а 50 руб., в февральское соответственно 0. Поэтому очень желательно при сторнированиях и возвратах НДФЛ правильно указывать за какой период происходит корректировка.

Ну и ложка дегтя. Обработка по заполнению документов писалась для ЗУП бюджетных учреждений от фирмы АРБИС. А в этой конфигурации месяц, за который перечисляется НДФЛ вынесен в табличную часть, поэтому на типовых не попрет, либо переделывать типовые (знаю что многие так и делают). Оно вообще-то так и удобнее и правильнее - не надо кучу документов городить по перечислению НДФЛ.
В этой же обработке в меню Действия можно просуммировать перечисленный НДФЛ на основании документов перечисление НДФЛ(еще не заполненных и даже не проведенных, лишь бы были общие суммы). Это может понадобиться на этапе, когда готовите почву перед распределением уплаченных сумм по людям.

Прикрепленный файлРазмерХитыПоследнее скачивание
PerechislenieNDFL.epf9.5 кб17084 дня 8 часов назад
RaschetyPoNDFL.erf6.69 кб15584 дня 8 часов назад

Комментарии

Выберите нужный метод показа комментариев и нажмите "Сохранить установки".

Извините за вопрос, но какой обработкой вносятся изменения в документ по возврату НДФЛ и заставляют его добавлять Приход со знаком минус в регистр Расчеты налоговых агентов по НДФЛ?

admin аватар

Это не обработкой. Это придется подправить конфигурацию, в частности модуль документа "НДФЛВозвратНалога". Куда-нибудь в конец процедуры надо вставить нечто подобное:

Процедура ОбработкаПроведения(Отказ, Режим)
.....
 
// ХА
Если Год(Дата) >= 2011 Тогда
	Для каждого СтрокаТЧ Из РаботникиОрганизации Цикл
		НачалоСообщения = "В строке № """ + СокрЛП(СтрокаТЧ.НомерСтроки) +
									""" табл. части ""Сотрудники организации"": ";
 
		Если Не ЗначениеЗаполнено(СтрокаТЧ.ФизЛицо) Тогда
			ОбщегоНазначения.ВывестиИнформациюОбОшибке(НачалоСообщения + "не указано физическое лицо!", Отказ, Заголовок);
		КонецЕсли;
 
		Если Не Отказ Тогда
			Движение = Движения.РасчетыНалоговыхАгентовСБюджетомПоНДФЛ.ДобавитьПриход();
			Движение.Период = Дата;
			Движение.МесяцНалоговогоПериода = МесяцНалоговогоПериода;
			Движение.ФизЛицо = СтрокаТЧ.ФизЛицо;
			Если ЗначениеЗаполнено(СтрокаТЧ.КодПоОКАТО) Тогда
				Движение.ОКАТО_КПП = СокрЛП(СтрокаТЧ.КодПоОКАТО) + "/" + СокрЛП(СтрокаТЧ.КПП);
			Иначе
				Движение.ОКАТО_КПП = СокрЛП(Организация.КодПоОКАТО) + "/" + СокрЛП(Организация.КПП);
			КонецЕсли;
			Движение.Организация = Организация;
			Движение.Ставка = Перечисления.НДФЛСтавки.Ставка13;
			Движение.Сумма = -СтрокаТЧ.СуммаВозвратаПоСтавке13;
		КонецЕсли;
	КонецЦикла;
КонецЕсли;
// 		ХА
....

Условие "Если Год(Дата) >= 2011 Тогда" вам надо будет естественно подкорректировать.

admin аватар

Добавил продолжение статьи:
http://www.allexx.info/perechislenie-ndfl-po-sotrudnikam-v-1s-zup-za-201...

Отправить комментарий

Содержание этого поля является приватным и не предназначено к показу.
  • Адреса страниц и электронной почты автоматически преобразуются в ссылки.
  • Доступны HTML теги: <a> <em> <strong> <cite> <code> <ul> <ol> <li> <dl> <dt> <dd>
  • Строки и параграфы переносятся автоматически.
  • You can enable syntax highlighting of source code with the following tags: <code>, <blockcode>, <1c7>, <drupal5>, <drupal6>, <javascript>, <php>. Beside the tag style "<foo>" it is also possible to use "[foo]".